Intercom Incident
Incident Report for Turtl
Resolved
This incident has been resolved.
Posted Oct 12, 2023 - 17:14 BST
Investigating
The third party service we use (Intercom) is currently experiencing technical difficulties, which is having an affect on our in-app chatbox for support and our Turtl Help Center.
Posted Oct 12, 2023 - 15:49 BST