Theme Creator and Known Readers temporarily unaccessible
Incident Report for Turtl
Postmortem

Due to an error with an internal config migration, all clients were affected by a brief unavailability of a few features of our product starting partially on August 4th, and partially on August 5th.

The issue was detected on the 8th of August and a large number of clients were fixed manually early in the day, while the remainder were fixed by the end of the day when we ran a second config migration to resolve the issue.

No data was lost during this period, as the config changes affected only the availability of certain user interface elements for license holders. Turtl Doc engagement was not affected in any way for readers.

We have now limited the ability of these types of config changes to affect the wider application, in order to prevent the same issue happening again.

Posted Aug 09, 2022 - 16:06 BST

Resolved
This incident has been resolved.
Posted Aug 08, 2022 - 22:20 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 08, 2022 - 21:44 BST
Investigating
We are investigating an issue where certain tenants cannot access Theme Creator and Known Readers. Please reach out to support@turtl.co with any questions

We're grateful for your patience while we resolved this issue and sorry for any frustration it caused.
Posted Aug 08, 2022 - 20:58 BST
This incident affected: Assets generation and Analytics reports.