Analytics of Immerse section is unavailable
Incident Report for Turtl
Postmortem

In the night between March 20th and March 21st, we released a large update to our Content Studio, adding new functionality for all clients.

The update had an unplanned impact on the viewing of docs, where in a large number of cases, analytics events were not being emitted correctly inside the immerse pages of docs.

We became aware of the problem in the early morning, when we began seeing discrepancies in the analytics dashboards of individual docs. Our team investigated and found the issue, but the events that were not emitted correctly were not recoverable.

In total, events are missing for a 9 hour window on March 21st.

Our engineering team have since added a battery of tests that would have surfaced this category of issue sooner, to prevent a similar problem from occurring in the future.

Posted Apr 05, 2024 - 14:00 BST

Resolved
This incident has been resolved.
Posted Mar 22, 2024 - 07:45 GMT
Update
The fix resolved analytics for all Docs. We continue to monitor the results.
Posted Mar 21, 2024 - 17:22 GMT
Update
The fix resolved analytics for all Docs, except for nested Docs. We are in the process of finding a fix for the latter and are continuing to monitor the issue.
Posted Mar 21, 2024 - 12:37 GMT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2024 - 11:26 GMT
Identified
Analytics events for the Immerse level have not been logged from 1.00 GMT this morning, 21st March. We have identified the issue and are in the process of applying a fix. Please check back here for updates.
Posted Mar 21, 2024 - 11:11 GMT
This incident affected: Analytics reports.