Investigating potential issues caused by the latest Chrome update
Incident Report for Turtl
Resolved
We are fully operational, thank you for your patience on this 🐢
Posted Sep 15, 2021 - 10:00 BST
Monitoring
A fix has been implemented and we are monitoring performance.

If you need any support, feel free to get in contact with the team who are more than happy to assist.
Posted Sep 14, 2021 - 10:37 BST
Investigating
We are investigating some potential issues that may occur due to the latest Chrome update, version 93.0.4577.63

If you are experiencing any problems in the Editor, please get in contact with the support team via the live chat or email support@turtl.co

Sorry for any inconvenience this may have caused!
Posted Sep 13, 2021 - 12:18 BST
This incident affected: Editor.