We are experiencing degraded performance on some tenants
Incident Report for Turtl
Resolved
This incident has been resolved.
Posted Aug 25, 2023 - 09:48 BST
Update
We are continuing to monitor for any further issues.
Posted Aug 25, 2023 - 08:49 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Aug 25, 2023 - 08:48 BST
Identified
The issue has been identified and a fix is being implemented.
Posted Aug 25, 2023 - 08:38 BST
Investigating
We are currently investigating Turtl platform being inaccessible for some of our customers.
Posted Aug 25, 2023 - 08:17 BST
This incident affected: Editor, Viewer, Assets generation, Analytics reports, and Personalization.