Degraded performance sending outbound emails
Incident Report for Turtl
Resolved
Postmark has resolved the incident and emails are now being delivered promptly.
Posted Feb 03, 2023 - 18:45 GMT
Monitoring
Postmark has identified the issue with sending delays and are monitoring a fix.
Posted Feb 03, 2023 - 18:38 GMT
Investigating
Our third-party email delivery service, Postmark, is experiencing degraded performance in sending outbound emails. This means password reset and activation emails may take longer to be delivered to your inbox.
Posted Feb 03, 2023 - 18:13 GMT