Personalization module access

Incident Report for Turtl

Resolved

This incident has been resolved.
Posted Jul 03, 2025 - 22:55 BST

Identified

The issue has been identified, and a fix is being implemented.
Posted Jul 03, 2025 - 20:00 BST

Investigating

We're currently investigating an issue that's preventing some users from accessing the Personalization module.
Our team is working to identify the cause and will provide an update as soon as more information is available. Thank you for your patience!
Posted Jul 03, 2025 - 18:17 BST
This incident affected: Personalization.