Analytics not available
Incident Report for Turtl
Resolved
This incident has been resolved.
Posted Jul 20, 2023 - 10:21 BST
Investigating
We are currently investigating an issue with our Analytics. We are working to fix it. Please check back here for updates.
Posted Jul 20, 2023 - 10:17 BST
This incident affected: Analytics reports.